
 1

 

TOPEX User Guide 
Version 1.0 
 
An extension to compute relief TOPographical EXposure with ArcView 3.2 

 
 

Third version: Pierre Racine, 2006 
Second version: Vincent Laflèche, 2001 

First version: Michel Dornier, 2001 
 

The TOPEX script was originally created at The Windthrow Research Group 
University of British Columbia, Vancouver, Canada 

 led by Dr. Stephen J. Mitchell 
http://faculty.forestry.ubc.ca/mitchell/windthrow.htm 

 
This version of TOPEX was first modified by Michel Dormier 

And then by Pierre Racine 
http://www.cef-cfr.ca/index.php?n=Membres.PierreRacine 

 
For use by Dr. Jean-Claude Ruel 

Centre d’étude de la forêt  
Université Laval, Canada 

http://www.cef-cfr.ca/index.php?n=Membres.JeanClaudeRuel 
 
 

 
INTRODUCTION 
 
TOPEX stands for TOPographical EXposure. This is a topographical index describing wind 
exposure. TOPEX is a program developed to run with the geographical information system 
ArcView 3.2 from the company ESRI. It is written in the language Avenue. Typically, you will want 
to compute the TOPEX value for every point of a raster dataset representing elevation. The result 
will be a new raster dataset containing a TOPEX index for every point. If your topographical data 
are not in a raster-based (i.e. they are in the form of a digital elevation model (DEM), contour lines 
or TIN – Triangulated Irregular Network), you will first have to convert them to the ESRI GRID 
raster format. 
 
Topographical exposure (or wind exposure) is a very important factor to consider when evaluating 
vegetation sensibility to windthrow. This recurrent phenomenon is very important in forestry. In the 
absence of major disturbances, it often determines the time when forest populations start to 
decline. It also influences the speed at which the canopy deteriorates. Windthrow risk has an 
impact on silviculture, in that it can restrict the management or harvesting options to foresters. In 
this context, it is important to understand the links between windthrow risk, natural population 
evolution and silviculture. 
 



 2

How TOPEX is computed 
 
The TOPEX index is the sum of the slope angles for eight compass directions around a target 
point. This index is computed for every point on a GRID raster containing elevation data. As you 
can see in Figure 1 and 2, the angles involved in computing the sum can be either positive or 
negative depending on whether the target point is lower or higher than the extremity (the reference 
point) used to compute the angle. As a result, the sum can also take positive or negative values.  
 

 

 
 

Figure 1: Angle calculation 
 when the target point is on a hill top 

 

 
 

Figure 2: Angle calculation 
 when the target point is at the bottom of 

the slope 
 
 
Based on a test site, the following TOPEX classes were defined: 
 

[-150 , -60] severely exposed 
[ -60  , -20] 
[ -20  ,  20] little exposed 
[  20  ,  60] 
[  60  ,150] very sheltered 
[ No data] values outside this range 
 

“No data” values sometimes correspond to errors incurred when digitizing the map.  
 
These classes are used in ArcView to map exposure hazards as shown in Figure 3. 
 

 
Figure 3: Example of ArcView exposure mapping 

based on the proposed classes 
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USING THE SCRIPT 
 
Prerequisites 
 
Software 
You will need ArcView 3.2 with the Spatial Analyst and 3D Analyst extensions installed. Most 
conversion procedures can be done with ArcView 3.2 but re recommend doing them with ArcGIS 
9.1 and above if you have access to a copy of this software. 
 
Data 
You need to have elevation data about the target area for which you want 
to compute the TOPEX. Ideally these data should be in ESRI GRID raster 
format. The appendix will show you how to obtain and convert different 
formats like DEM, contour lines and TIN to the ESRI GRID raster format (or 
ArcGRID). In order to avoid incorrect measurements, the GRID raster 
should be projected in the UTM coordinate system. The correct UTM coordinate system zone is 
determined following the geographical area covered by the data. Typically, UTM zones for North 
America range from 9 to 21 proceeding from west to east. See the end of the appendix for a map 
of UTM zones. 
 
Procedure 
 
Here is the procedure to compute TOPEX values for an ESRI GRID raster dataset. 
 
1. Double-click on the TOPEX.APR project. It should open in ArcView. 

 
If APR files are not associated with ArcView on your computer, start ArcView first and then 
check “Open an existing project”. Browse to the folder containing TOPEX.APR and select this 
file. Make sure the project file is not in a folder containing a space. 
 
If you do not see the window asking to load a project, select “File ->Open Project…” from the 
menu. Browse to the folder containing TOPEX.APR and select it. 
 

 
Figure 4: ArcView with TOPEX.APR loaded 

 

• The appendix will 
show you how to 
obtain and convert 
elevation data  
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You should now have an empty ArcView window like the one in Figure 4. 
 

 
 

2. Create a new view and open the GRID raster containing elevation data 
 

a. Select “Views” in the project window 
 
b. Click on the “New” button   
 
c. Select  “View -> Add Theme” from the ArcView menu (or CTRL-T) 
 
d. Select “Grid data source” as Data Source Types 
 
e. Browse and select your GRID raster file and click “OK” 
 
f. Make sure the theme is displayed by checking the box next to the theme's name in the view 
 
You should now have a view similar to the one in Figure 5. 
 

 
 

Figure 5: ArcView with TOPEX ready and a GRID raster loaded 
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3. Select the target area 
 
The script can compute the TOPEX for a complete GRID raster or only for a part of the raster. 
TOPEX computation is generally very long. Be sure to restrict yourself to the minimal area 
corresponding to your needs. 
 
a. You might want to zoom to the target area using the “Zoom” tool before selecting the zone 

for which you want to compute the TOPEX. Select the rectangle tool as shown in Figure 6.  
 

b. Select the computation area by drawing a rectangle over the raster. You must select an area 
smaller than the grid so that a buffer zone at least equal to the limit distance set for TOPEX 
calculation (in the TOPEX dialogue box, see below Topex Distance) remains. If you are 
about to select a distance of 1000 m, make sure there is at least 1000 m available around 
each side of the selected rectangle. Otherwise, you could receive the error message “Can’t 
convert string to number: Number.” 

 
 

 
 

Figure 6: Selecting the rectangle tool 
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4. Execute the TOPEX script 
 

a. Click on the TOPEX icon  
 
b. A dialogue box like the one in Figure 7 should open 
 

 
 

Figure 7: The TOPEX dialogue box 
 

c. Set the following options: 
 

Select Input Surface: Normally, the loaded GRID raster should be automatically selected. If 
you have more than one raster opened, select the one for which you want to compute the 
TOPEX. 
 
Choose Method: If you have selected an area using the rectangle tool, click the “selected 
area” option button. If you want to compute for the whole raster, click “grid extent”. 
Remember that computing TOPEX for the whole raster can take many hours. 
 
Output file: When computing TOPEX for a large area, if for some reason the process 
crashes, the state of the process will be saved in the file you have specified. If this happens, 
you can restart and resume the process in another TOPEX session by selecting the file you 
had specified before the process crashed. 
 
Cardinal Angles: This is the number of cardinal direction for which you can compute the 
TOPEX. 360 divided by this number should give an integer. Although 8 is the standard 
value, 2, 3, 4, 6 or any divisor of 360 are valid. The “Weight” button is inactive for now. 
 
Topex Distance: This is the maximal distance from the point being analyzed from which the 
script will try to compute the slope. The greater the distance; the longer the computation, as 
TOPEX has to check every intervening point to find the highest or lowest point to use when 
computing the slope. Use the ArcView measure tool  to make sure you set a reasonable 
value. The correct distance depends on the scale of the file and the topography of the area. 
Try to choose a value that encompasses the main topographical features surrounding the 
computing area. The distance is in the same units as the cell size of the GRID raster. To 
determine the cell size, select “Theme->Properties” from the ArcView menu. If the cell size is 
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1 and you select a distance of 100, then a hundred points will be checked to determine the 
correct slope; this process will be repeated for every cardinal directions. Typically, your file 
will be projected to UTM and the cell size will be expressed in meters. You can double-
check this by measuring the edge of a pixel in the raster. For 30-meters DEM, the edge 
should measure 30 meters. 

 
d. Click “OK”. The computation should begin… 
 
e. If the computation takes too long and you want to cancel the process, click on the “Stop” 

button appearing at the bottom right corner of the ArcView window. You might have to click 
more than once for this to work… 

 
5. Symbolise the resulting raster 
 

a. Make sure the resulting raster theme is displayed by checking the box next to the theme's 
name in the view 

 
b. Double-click on the legend box. The Legend Editor should appear 
 
c. Click the load button and browse to open the TOPEX_Legend.avl file. The Legend Editor 

should display standard categories, as in Figure 8. 
 

 
 

Figure 8: The Legend Editor dialogue box with the TOPEX legend loaded 
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d. Click on “Apply” and close the dialogue 
 
 

6. Save the generated raster 
 

a. From the “Theme” menu, select “Save Data Set…” 
 
b. Browse and give a name to the raster 
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APPENDIX 
 
How to obtain elevation data and convert them to GRID raster 
 
ArcView 3.2 already is old software. Unfortunately, the more recent versions of this GIS (ArcGIS 8 
and above) do not support Avenue, the language which was used to develop TOPEX. ArcGIS is 
much more efficient when converting data from one format to another. We will first explain how to 
convert elevation data to GRID raster using ArcGIS 9.1, and then using ArcView 3.2. If you have 
access to a copy of ArcGIS, we recommend using this software to do the conversions even if 
TOPEX calculations will be performed in ArcView. 
 
 

 
Obtaining DEM data 
 
Digital Elevation Data (DEM) is one of the most current formats used to exchange elevation data.  
 
Canada 
 
DEM for Canada are called Canadian Digital Elevation Data (CDED). They can be found at: 
 

• GeoBase (http://www.geobase.ca/geobase/fr/data/cded1.html) 
• DMTI (http://www.dmtispatial.com/digi_elev_model.htm) 

 
GeoBase data are free. DMTI data cost a fee, but are of better quality. Your university map library 
might have an agreement with DMTI, thereby giving you free access to these files. It is worth 
checking. 
 
CDED files have a DEM extension. They must be converted to GRID and projected to the UTM 
coordinate system in order to be used with TOPEX.  
 
United States 
 
Information about DEM for the United States can be found on the USGS 
(United States Geological Survey) site at: 
  

• Digital Elevation Models (DEMs) (http://eros.usgs.gov/products/elevation.html) 
• USGS Geographic Data Download (http://eros.usgs.gov/geodata/). Select “1:24,000 Scale 

Digital Elevation Models (DEM) SDTS format only” 
 
These DEM can be downloaded for free from many sites: 
 

• GeoCommunity (http://data.geocomm.com/dem/demdownload.html) 
• MapMart (http://www.mapmart.com/DEM/DEM.htm) 
• ADTI (http://www.atdi-us.com/SDTS_DL_b.htm) 

 

• CDED DEM = Canada 
• SDTD DEM = USA 
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These DEM are generally in the Spatial Data Transfer Standard (SDTS) format, which consists of a 
set of files with the DDF extension. They must be converted to GRID before using them with 
TOPEX. They are already projected to UTM. 
 
USGS have replaced DEM with a new enhanced product called NED (National Elevation Data). 
They can be downloaded at: 
 

•  USGS NED (http://ned.usgs.gov/) 
 
NED data are already in the ESRI GRID format so they do not need to be converted. However, 
they still have to be projected to UTM to be used with TOPEX. 
 

 
Converting CDED DEM to GRID using ArcGIS 9.1 
 
1. Convert CDED DEM to raster using the “DEM to Raster” AcrToolBox tool 
 

a. In ArcToolBox, double-click on the “Conversion Tools”, on the “To Raster” section and then 
on the “DEM To Raster” tool 

 
b. Select your DEM file as “Input USGS DEM file” or drag it from the ArcCatalog tree 
 
c. Modify the proposed “Output raster” file name, if desired 
 
d. Keep the “Output Data Type” to FLOAT and click “OK” 

 
2. Convert from decimal second to decimal degree using the “Project Raster” ArcToolBox 

tool 
 
CDED files are in a geographic coordinate system with angular units in decimal seconds. In 
order to display them correctly in ArcGIS, you must use the Project Raster tool to convert them 
to decimal degrees. 
 
You can skip this step and go directly to “Projecting GRID to UTM using ArcGIS 9.1” if you 
have to project the raster to the UTM coordinate system anyway. 
 
a. In ArcToolBox, double-click on the “Conversion Tools”, on the “Projection and 

Transformations” section and then on the “Project Raster” tool 
 
b. Select your raster file as “Input raster” or drag it from the ArcCatalog tree 
 
c. Modify the proposed “Output raster” file name, if desired 

 
d. Click on the “Coordinate System Button” and then on the “Select” button 

 
e. Navigate and select the “Geographic coordinate Systems -> North America -> North 

American Datum 1983.prj” coordinate system and click “Add” and then “OK” 
 

f. Click “OK” in the Project Raster tool window 
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The resulting raster will have the angular unit set to Decimal Degrees. 
 

See also: 
 

• http://library.usask.ca:9003/data/geography/nrcan/CDED-tutorial.pdf 
• http://www.mcgill.ca/files/gic/CDED9.pdf 

 
 

 
Converting SDTS DEM to GRID using ArcGIS 9.1 
 
1. Make sure the Arcview 8.x “Conversion Tools” toolbar is active 
 

a. From the “View” menu, select “Toolbars” and then “Arcview 8.x Tools” 
 
2. Convert the file using the “SDTS Raster To GRID” tool from the “Conversion Tools” 

toolbar 
 

a. From the “Conversion Tools” toolbar, select “SDTS Raster To GRID…” 
 
b. To fill the “Input prefix:” field, browse to the folder containing the SDTS DEM file 

 
c. Select the prefix corresponding to your set of DDF files 

 
d. Make sure the “Record no.:” field correspond to the field containing elevation data 

 
e. Set the name of the output GRID and click “OK” 

 
 

 
Converting Contour lines to GRID using ArcGIS 9.1 
 
It is possible to construct an elevation GRID from topographical contour lines. However, we do not 
recommend this as you might might produce erroneous data. Instead, you should try to get the 
DEM files from the above sources and convert them to GRID. These files have already passed 
through a correction process and should be of much better quality than what you would get by 
converting contour lines files. Use contour lines files ONLY if you have no other options. 
 
First technique using ArcGIS 3D Analyst 
 
1. Create a TIN using the “Create TIN from Features…” tool of the “3D Analyst” toolbar  
 

a. Start ArcMap and make sure the “3D Analyst” toolbar is displayed. You can do this by first 
selecting “Tools” and then “Extensions” from the menu, and then check the “3D Analyst” 
check box. You then have to display the toolbar by right-clicking in  the space to the right of 
the menu and selecting “3D Analyst” 

 
b. From the “3D Analyst” toolbar menu, choose “Create/Modify TIN” and then “Create TIN 

from Features” 
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c. Open the layer (shapefile) containing the contour lines from which you want to create the 

TIN 
 

d. Beside the “Height source” text, select the field containing the elevation values and select 
“soft line” as the triangulation method 

 
e. Click “OK” 

 
2. Convert the TIN to a GRID using the “TIN to Raster…” tool of the “3D Analyst” toolbar 
 

a. From the “3D Analyst” toolbar menu, choose “Convert” and then “TIN to Raster…” 
 
b. Select the TIN you just created as “Input TIN” 

 
c. Set the Attribute to “Elevation” 

 
d. Leave the Z factor set to 1 

 
e. Set the cell size in order to get a raster with the number of rows and columns you want. 

The value should be between 0 and 1. 
 

f. Set a name for the output GRID raster and click “OK” 
 
See also: 
 

• http://web.austin.utexas.edu/architecture/courses/parmenter/gis/arcgis_tips/create-tin.html 
 
 

 
Projecting GRID to UTM using ArcGIS 9.1 

 
You DO NOT have to project GRID produced from SDTS DEM files as they already are in the UTM 
coordinate system. However, you DO HAVE to project GRID produced from other sources in order 
to use them with TOPEX. 
 

a. In ArcToolBox, double-click on the “Data Management Tools”, on the “Projections and 
Transformations”, on the “Raster” section and then on the “Project Raster” tool 

 
b. Select your raster file as the “Input raster” or drag it from the ArcCatalog tree 
 
c. Modify the proposed “Output raster” file name, if desired 
 
d. Click on the “Coordinate System Button” and then on the “Select” button 
 
e. Navigate to “Projected Coordinate Systems -> UTM -> Nad 1983” and then select the 

projection file corresponding to the zone of your dataset. Click “Add” and then “OK” 
 
f. Click “OK” in the “Project Raster” tool window 

 



 13

 

 
Converting CDED DEM to GRID using ArcView 3.2 
 
1. Install the DEMShift Avenue script 
 

a. Download this Avenue script from the ESRI site: 
 

http://arcscripts.esri.com/details.asp?dbid=10711 
 
b. Open ArcView, click on the “Script” button in the Project window and then click on “New” 
 
c. Copy the content of the downloaded file into the empty window as in Figure A1 
 

 
 

Figure A1: ArcView 3.2 with the DEMShift script loaded and ready to compile. 
Notice the mouse pointing on the Compile button 

 

d. Click on the “Compile” button  
 

2. Execute the DEMShift Avenue script  
 

a. Click on the “Run” button 
 
b. You should get a dialogue like the one in Figure A2 
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Figure A2: The DEMShift script dialogue box 
 

c. Browse to select your CDED DEM file 
 
d. Set an Output file name and click “OK”. If the script ends with an error, just click “OK”. 

 
3. Create a new view and open the created raster 
 
See also: 
 

• http://www.brocku.ca/maplibrary/procedures/CDEDinAV.htm 
 
 

 
Converting SDTS DEM to GRID using ArcView 3.2 
 
The following procedure will explain how to convert SDTD DEM to GRID using ArcView 3.2: 
 
http://support.esri.com/index.cfm?fa=knowledgebase.techarticles.articleShow&d=16605 
 
See also: 
 

• http://www.esri.com/news/arcuser/0100/webdata8.html 
• http://www.esri.com/news/arcuser/0400/webdata9.html 
• http://web.austin.utexas.edu/architecture/courses/parmenter/gis/tips/DEM-import.html 

 
 

 
Converting Contour lines to GRID using ArcView 3.2 
 
First technique using ArcView 3D Analyst 
 
1. Create a TIN using “Create TIN from Features…” from the “Surface” menu 
 

a. Create a new view and open the contour line shape file 
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b. Make sure the “Surface” menu is available. If not, select “Extensions…” from the “File” 

menu and then check the “3D Analyst” check box 
 
c. In the “Surface” menu, select “Create TIN from Features…” 
 
d. If there are many themes loaded, make sure the right contour line feature theme is 

selected at the left of the view window 
 
e. Select the field containing the elevation values as “Height source” and “soft line” for the 

“Input as…” field 
 
f. Click “OK” and select an output file name for the TIN 
 
g. ArcView should add the created TIN to the view 

 
 
2. Convert the TIN to a GRID using “Convert to Grid…” from the “Theme” menu 
 

a. Make sure the TIN theme is highlighted in the view window 
 
b. From the “Theme” menu, select “Convert to Grid…” 
 
c. Select the location for the output grid 
 
d. A dialogue like the one in Figure A3 should appear 

 

 
 

Figure A3: The Convert Theme to Grid ArcView 3.2 dialogue box 
 

e. Make sure the “Output Grid Extent” is the one of the TIN 
 
f. Set the “Output Grid Cell Size”, “Number of Rows” and “Number of Columns” to values 

reflecting the size of the raster you want and click “OK” 
 
See also: 
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• http://www.ce.utexas.edu/prof/maidment/grad/azagra/Research/tin.htm 

 
 

 
Projecting GRID to UTM using ArcView 3.2 
 

a. From the ArcView “File” menu select “Extensions…” and then check the “Grid Projector” 

check box. A button like this  should appear 
 
b. Create a new view, open the GRID raster to be converted and make it the theme active 
 
c. Make sure the Map Units are “decimal degrees” and the Distance Units are “unknown” in 

the “View ->Properties” dialogue 
 
d. Click on the Grid Projector button and select "meters" as the output units 
 
e. From the “Projection Properties” dialogue box, select “UTM -1983” from the Category 

dropdown list and the zone corresponding to your dataset from the “Type” dropdown list. 
Click “OK”. You can refer to Figure A4 to determine the right UTM zone 

 
f. Select the view in which you want the new raster to appear and click “OK” 
 
g. To save a permanent copy of the GRID, select “Theme -> Save”, navigate to the directory 

to save the data, give the file an appropriate name and click “OK” 
 
See also: 
 

• http://www.brocku.ca/maplibrary/procedures/dd2utm.htm 
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UTM Zones 
 
Figure A4 shows a map with the different UTM zones for North America 
 

 
 

Figure A4: UTM zones 
 


